blob: 45d6be31ec95c5548b6e5b8ccae8ffa514dfa22b [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
Brad Bishope42b3e32020-01-15 22:08:42 -05005
6LIC_FILES_CHKSUM = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007 file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
8 file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -05009"
10
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRC_URI = " \
12 git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
Patrick Williams73bd93f2024-02-20 08:07:48 -060013 file://0001-media_device-Add-bool-return-type-to-unlock.patch \
14 file://0002-options-Replace-use-of-VLAs-in-C.patch \
Patrick Williams39653562024-03-01 08:54:02 -060015 file://0001-rpi-Use-alloca-instead-of-variable-length-arrays.patch \
Patrick Williams03514f12024-04-05 07:04:11 -050016 file://0001-ipu3-Use-posix-basename.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050017"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
Patrick Williams73bd93f2024-02-20 08:07:48 -060019SRCREV = "89227a428a82e724548399d35c98ea89566f9045"
Brad Bishope42b3e32020-01-15 22:08:42 -050020
Patrick Williams2390b1b2022-11-03 13:47:49 -050021PE = "1"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
23S = "${WORKDIR}/git"
24
Patrick Williams2194f502022-10-16 14:26:09 -050025DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls chrpath-native libevent libyaml"
Brad Bishope42b3e32020-01-15 22:08:42 -050026DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
27
Andrew Geisslerd688a012020-09-18 13:36:00 -050028PACKAGES =+ "${PN}-gst"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
32
Patrick Williamse760df82023-05-26 11:10:49 -050033LIBCAMERA_PIPELINES ??= "auto"
34
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000035EXTRA_OEMESON = " \
Patrick Williamse760df82023-05-26 11:10:49 -050036 -Dpipelines=${LIBCAMERA_PIPELINES} \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000037 -Dv4l2=true \
38 -Dcam=enabled \
39 -Dlc-compliance=disabled \
40 -Dtest=false \
41 -Ddocumentation=disabled \
42"
43
Patrick Williams213cb262021-08-07 19:21:33 -050044RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
Brad Bishope42b3e32020-01-15 22:08:42 -050045
46inherit meson pkgconfig python3native
47
Patrick Williams213cb262021-08-07 19:21:33 -050048do_configure:prepend() {
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070049 sed -i -e 's|py_compile=True,||' ${S}/utils/ipc/mojo/public/tools/mojom/mojom/generate/template_expander.py
50}
51
Patrick Williams213cb262021-08-07 19:21:33 -050052do_install:append() {
Patrick Williams2390b1b2022-11-03 13:47:49 -050053 chrpath -d ${D}${libdir}/libcamera.so
Patrick Williams2a254922023-08-11 09:48:11 -050054 chrpath -d ${D}${libexecdir}/libcamera/v4l2-compat.so
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050055}
56
Andrew Geissler20137392023-10-12 04:59:14 -060057do_package:append() {
58 bb.build.exec_func("do_package_recalculate_ipa_signatures", d)
59}
60
61do_package_recalculate_ipa_signatures() {
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050062 local modules
63 for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
64 module="${module%.sign}"
65 if [ -f "${module}" ] ; then
66 modules="${modules} ${module}"
67 fi
68 done
69
70 ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
71}
72
Patrick Williams2a254922023-08-11 09:48:11 -050073FILES:${PN} += " ${libexecdir}/libcamera/v4l2-compat.so"
Patrick Williams2390b1b2022-11-03 13:47:49 -050074FILES:${PN}-gst = "${libdir}/gstreamer-1.0"
Andrew Geissler517393d2023-01-13 08:55:19 -060075
76# libcamera-v4l2 explicitly sets _FILE_OFFSET_BITS=32 to get access to
77# both 32 and 64 bit file APIs.
78GLIBC_64BIT_TIME_FLAGS = ""