Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 1 | SUMMARY = "pflash programmer for OpenPower" |
| 2 | DESCRIPTION = "pflash firmware programming tool for OpenPower machines" |
| 3 | HOMEPAGE = "https://github.com/open-power" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | SRC_URI += "git://github.com/open-power/skiboot.git" |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 7 | |
| 8 | SRC_URI += "file://0001-Make-links-target-reusable.patch" |
| 9 | SRC_URI += "file://0002-external-Remove-external-shared-link-targets.patch" |
| 10 | SRC_URI += "file://0003-external-Fix-pflash-install-target.patch" |
| 11 | SRC_URI += "file://0004-external-Remove-m64-from-shared-CFLAGS-on-ARM.patch" |
| 12 | SRC_URI += "file://0005-external-Create-shared-rules.mk.patch" |
| 13 | SRC_URI += "file://0006-external-Add-dynamically-linked-pflash.patch" |
Brad Bishop | 642b5f4 | 2016-06-21 13:23:47 -0400 | [diff] [blame] | 14 | SRC_URI += "file://0007-external-Fix-ARM-build-failure-with-parallel-make.patch" |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 15 | |
Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 16 | LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 17 | |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 18 | SRCREV = "skiboot-5.2.2" |
| 19 | PV = "5.2.2" |
Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1' |
| 24 | |
| 25 | do_compile () { |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 26 | oe_runmake -C external/pflash all LINKAGE=dynamic |
Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 27 | } |
| 28 | |
| 29 | do_install () { |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 30 | oe_runmake -C external/pflash install LINKAGE=dynamic DESTDIR=${D} PREFIX=${D}/usr |
Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 31 | } |
Brad Bishop | f64e73c | 2016-06-08 23:06:31 -0400 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |