blob: ec43b4f62a72768d1588347eb333b970fee1b27f [file] [log] [blame]
Joel Stanley34c894e2015-12-06 22:54:23 +10301SUMMARY = "pflash programmer for OpenPower"
2DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
3HOMEPAGE = "https://github.com/open-power"
4LICENSE = "Apache-2.0"
5
6SRC_URI += "git://github.com/open-power/skiboot.git"
Brad Bishopf64e73c2016-06-08 23:06:31 -04007
8SRC_URI += "file://0001-Make-links-target-reusable.patch"
9SRC_URI += "file://0002-external-Remove-external-shared-link-targets.patch"
10SRC_URI += "file://0003-external-Fix-pflash-install-target.patch"
11SRC_URI += "file://0004-external-Remove-m64-from-shared-CFLAGS-on-ARM.patch"
12SRC_URI += "file://0005-external-Create-shared-rules.mk.patch"
13SRC_URI += "file://0006-external-Add-dynamically-linked-pflash.patch"
Brad Bishop642b5f42016-06-21 13:23:47 -040014SRC_URI += "file://0007-external-Fix-ARM-build-failure-with-parallel-make.patch"
Brad Bishopf64e73c2016-06-08 23:06:31 -040015
Joel Stanley34c894e2015-12-06 22:54:23 +103016LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
17
Brad Bishopf64e73c2016-06-08 23:06:31 -040018SRCREV = "skiboot-5.2.2"
19PV = "5.2.2"
Joel Stanley34c894e2015-12-06 22:54:23 +103020
21S = "${WORKDIR}/git"
22
23EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1'
24
25do_compile () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040026 oe_runmake -C external/pflash all LINKAGE=dynamic
Joel Stanley34c894e2015-12-06 22:54:23 +103027}
28
29do_install () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040030 oe_runmake -C external/pflash install LINKAGE=dynamic DESTDIR=${D} PREFIX=${D}/usr
Joel Stanley34c894e2015-12-06 22:54:23 +103031}
Brad Bishopf64e73c2016-06-08 23:06:31 -040032
33BBCLASSEXTEND = "native nativesdk"