Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer" |
| 2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ |
| 3 | library designed to provide low level access to audio, keyboard, mouse, \ |
| 4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." |
| 5 | HOMEPAGE = "http://www.libsdl.org" |
| 6 | BUGTRACKER = "http://bugzilla.libsdl.org/" |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Zlib" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b2304ad7e91711027590d3f102a754b7" |
| 12 | |
| 13 | PROVIDES = "virtual/libsdl2" |
| 14 | |
| 15 | DEPENDS_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}" |
| 16 | |
| 17 | SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ |
| 18 | file://linkage.patch" |
| 19 | |
| 20 | S = "${WORKDIR}/SDL2-${PV}" |
| 21 | |
| 22 | SRC_URI[md5sum] = "44fc4a023349933e7f5d7a582f7b886e" |
| 23 | SRC_URI[sha256sum] = "da55e540bf6331824153805d58b590a29c39d2d506c6d02fa409aedeab21174b" |
| 24 | |
| 25 | inherit autotools lib_package binconfig pkgconfig |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ |
| 28 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ |
| 29 | --disable-video-dummy \ |
| 30 | --enable-pthreads \ |
| 31 | --enable-sdl-dlopen \ |
| 32 | --disable-rpath" |
| 33 | |
| 34 | # opengl packageconfig factored out to make it easy for distros |
| 35 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL |
| 36 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl', '', d)}" |
| 37 | |
| 38 | PACKAGECONFIG ??= " \ |
| 39 | ${PACKAGECONFIG_GL} \ |
| 40 | ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \ |
| 41 | ${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \ |
| 42 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \ |
| 43 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ |
| 44 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ |
| 45 | " |
| 46 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," |
| 47 | PACKAGECONFIG[directfb] = "--enable-video-directfb --disable-video-directfb,directfb" |
| 48 | PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" |
| 49 | PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" |
| 50 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" |
| 51 | PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib" |
| 52 | PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland libxkbcommon" |
| 53 | PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" |
| 54 | |
| 55 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" |
| 56 | |
| 57 | do_configure_prepend() { |
| 58 | # Remove old libtool macros. |
| 59 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 60 | for i in ${MACROS}; do |
| 61 | rm -f ${S}/acinclude/$i |
| 62 | done |
| 63 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR |
| 64 | } |
| 65 | |
| 66 | FILES_${PN}-dev += "${libdir}/cmake" |