Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Command line tool and library for client-side URL transfers" |
| 2 | HOMEPAGE = "http://curl.haxx.se/" |
| 3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac" |
| 7 | |
| 8 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2" |
| 9 | |
| 10 | # curl likes to set -g0 in CFLAGS, so we stop it |
| 11 | # from mucking around with debug options |
| 12 | # |
| 13 | SRC_URI += " file://configure_ac.patch" |
| 14 | |
| 15 | SRC_URI[md5sum] = "9ea3123449439bbd960cd25cf98796fb" |
| 16 | SRC_URI[sha256sum] = "ddc643ab9382e24bbe4747d43df189a0a6ce38fcb33df041b9cb0b3cd47ae98f" |
| 17 | |
| 18 | inherit autotools pkgconfig binconfig multilib_header |
| 19 | |
| 20 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)} gnutls proxy zlib" |
| 21 | PACKAGECONFIG_class-native = "ipv6 proxy ssl zlib" |
| 22 | PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl zlib" |
| 23 | |
| 24 | PACKAGECONFIG[dict] = "--enable-dict,--disable-dict," |
| 25 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" |
| 26 | PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher," |
| 27 | PACKAGECONFIG[imap] = "--enable-imap,--disable-imap," |
| 28 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 29 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap," |
| 30 | PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps," |
| 31 | PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn" |
| 32 | PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2" |
| 33 | PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3," |
| 34 | PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy," |
| 35 | PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump" |
| 36 | PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp," |
| 37 | PACKAGECONFIG[smb] = "--enable-smb,--disable-smb," |
| 38 | PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp," |
| 39 | PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl" |
| 40 | PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet," |
| 41 | PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp," |
| 42 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib" |
| 43 | |
| 44 | EXTRA_OECONF = " \ |
| 45 | --enable-crypto-auth \ |
| 46 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ |
| 47 | --without-libmetalink \ |
| 48 | --without-libpsl \ |
| 49 | --without-nghttp2 \ |
| 50 | " |
| 51 | |
| 52 | do_install_append() { |
| 53 | oe_multilib_header curl/curlbuild.h |
| 54 | } |
| 55 | |
| 56 | do_install_append_class-target() { |
| 57 | # cleanup buildpaths from curl-config |
| 58 | sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config |
| 59 | } |
| 60 | |
| 61 | PACKAGES =+ "lib${BPN}" |
| 62 | |
| 63 | FILES_lib${BPN} = "${libdir}/lib*.so.*" |
| 64 | RRECOMMENDS_lib${BPN} += "ca-certificates" |
| 65 | |
| 66 | FILES_${PN} += "${datadir}/zsh" |
| 67 | |
| 68 | BBCLASSEXTEND = "native nativesdk" |