Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework" |
| 2 | LICENSE = "GPL-3.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | intltool-native \ |
| 7 | babl \ |
| 8 | glib-2.0 \ |
| 9 | cairo \ |
| 10 | expat \ |
| 11 | zlib \ |
| 12 | \ |
| 13 | json-glib \ |
| 14 | " |
| 15 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 16 | DEPENDS:append:toolchain-clang = " openmp" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 17 | DEPENDS:remove:toolchain-clang:riscv32 = "openmp" |
| 18 | DEPENDS:remove:toolchain-clang:powerpc = "openmp" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 19 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 20 | VALA_MESON_OPTION = "" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 22 | inherit features_check gnomebase gobject-introspection vala |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | |
| 24 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 25 | |
| 26 | SHPV = "${@gnome_verdir("${PV}")}" |
| 27 | |
| 28 | SRC_URI = "https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz" |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 29 | SRC_URI[sha256sum] = "418c26d94be8805d7d98f6de0c6825ca26bd74fcacb6c188da47533d9ee28247" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | |
| 31 | PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg pango poppler sdl2" |
| 32 | PACKAGECONFIG:class-native = "libpng librsvg" |
| 33 | |
| 34 | PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper" |
| 35 | PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2" |
| 36 | PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz" |
| 37 | PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg" |
| 38 | PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms" |
| 39 | PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav" |
| 40 | PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng" |
| 41 | PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw" |
| 42 | PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg" |
| 43 | PACKAGECONFIG[pango] = "-Dpango=enabled -Dpangocairo=enabled,-Dpango=disabled -Dpangocairo=disabled,pango" |
| 44 | PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler" |
| 45 | PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,libsdl" |
| 46 | PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2" |
| 47 | PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff" |
| 48 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp" |
| 49 | |
| 50 | # There are a couple of non-symlink .so files installed into libdir, which need to go into main package |
| 51 | FILES:${PN} += " \ |
| 52 | ${libdir}/*.so \ |
| 53 | ${libdir}/gegl-${SHPV}/*.json \ |
| 54 | ${libdir}/gegl-${SHPV}/*.so \ |
| 55 | " |
| 56 | FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}" |
| 57 | |
| 58 | # Fails to build with thumb-1 (qemuarm) |
| 59 | # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process': |
| 60 | # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 |
| 61 | ARM_INSTRUCTION_SET = "arm" |
| 62 | |
| 63 | BBCLASSEXTEND = "native" |