blob: 69d74567c393685b0195c462af82dbd3365268dd [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Thin-wrapper around the mock package for easier use with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \
6"
7
8SRC_URI = " \
9 git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
10 file://run-ptest \
11"
12
Patrick Williams520786c2023-06-25 16:20:36 -050013SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
Andrew Geissler3eeda902023-05-19 10:14:02 -050014
15SRC_URI[sha256sum] = "fbbdb085ef7c252a326fd8cdcac0aa3b1333d8811f131bdcc701002e1be7ed4f"
16
17inherit setuptools3 ptest
18
19DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
20
Patrick Williamsb542dec2023-06-09 01:26:37 -050021RDEPENDS:${PN} += " \
22 python3-asyncio \
23 python3-pytest \
24 python3-unittest \
25"
26
Andrew Geissler3eeda902023-05-19 10:14:02 -050027S = "${WORKDIR}/git"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests ${D}${PTEST_PATH}/
32}