Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "Thin-wrapper around the mock package for easier use with pytest" |
| 2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \ |
| 6 | " |
| 7 | |
| 8 | SRC_URI = " \ |
| 9 | git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 13 | SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI[sha256sum] = "fbbdb085ef7c252a326fd8cdcac0aa3b1333d8811f131bdcc701002e1be7ed4f" |
| 16 | |
| 17 | inherit setuptools3 ptest |
| 18 | |
| 19 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| 20 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} += " \ |
| 22 | python3-asyncio \ |
| 23 | python3-pytest \ |
| 24 | python3-unittest \ |
| 25 | " |
| 26 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | do_install_ptest() { |
| 30 | install -d ${D}${PTEST_PATH}/tests |
| 31 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 32 | } |