blob: 5ec7e6e9afafc4826c7b419f559d4aa43bf8a53c [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
6SRC_URI[sha256sum] = "9330fc7faa1db67b541b28e62018c17d20be733177d290a13b24c62d1614e0c3"
7
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williamsb542dec2023-06-09 01:26:37 -050014RDEPENDS:${PN} += " \
15 python3-datetime \
16 python3-profile \
17 python3-stringold \
18"
19
Andrew Geissler3eeda902023-05-19 10:14:02 -050020RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-poetry-core \
22 ${PYTHON_PN}-pytest \
23 ${PYTHON_PN}-pyyaml \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}