Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Implementation of a fully functional filesystem in a userspace program" |
| 2 | DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \ |
| 3 | programs to export a virtual filesystem to the Linux kernel. FUSE \ |
| 4 | also aims to provide a secure method for non privileged users to \ |
| 5 | create and mount their own filesystem implementations. \ |
| 6 | " |
| 7 | HOMEPAGE = "https://github.com/libfuse/libfuse" |
| 8 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "GPL-2.0-only & LGPL-2.0-only" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 11 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 12 | |
| 13 | SRC_URI = "https://github.com/libfuse/libfuse/releases/download/${BP}/${BP}.tar.gz \ |
| 14 | file://gold-unversioned-symbol.patch \ |
| 15 | file://aarch64.patch \ |
| 16 | file://0001-fuse-fix-the-return-value-of-help-option.patch \ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | file://fuse2-0007-util-ulockmgr_server.c-conditionally-define-closefro.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | file://fuse.conf \ |
| 19 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 20 | SRC_URI[md5sum] = "8000410aadc9231fd48495f7642f3312" |
| 21 | SRC_URI[sha256sum] = "d0e69d5d608cc22ff4843791ad097f554dd32540ddc9bed7638cc6fea7c1b4b5" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | |
| 23 | UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases" |
| 24 | UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>2(\.\d+)+).tar.gz" |
| 25 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 26 | CVE_PRODUCT = "fuse_project:fuse" |
| 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | inherit autotools pkgconfig update-rc.d systemd |
| 29 | |
| 30 | INITSCRIPT_NAME = "fuse" |
| 31 | INITSCRIPT_PARAMS = "start 3 S . stop 20 0 6 ." |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | SYSTEMD_SERVICE:${PN} = "" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | |
| 35 | DEPENDS = "gettext-native" |
| 36 | |
| 37 | PACKAGES =+ "fuse-utils libulockmgr libulockmgr-dev" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RPROVIDES:${PN}-dbg += "fuse-utils-dbg libulockmgr-dbg" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | RRECOMMENDS:${PN}:class-target = "kernel-module-fuse libulockmgr fuse-utils" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN} += "${libdir}/libfuse.so.*" |
| 44 | FILES:${PN}-dev += "${libdir}/libfuse*.la" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:libulockmgr = "${libdir}/libulockmgr.so.*" |
| 47 | FILES:libulockmgr-dev += "${libdir}/libulock*.la" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 48 | |
| 49 | # Forbid auto-renaming to libfuse-utils |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:fuse-utils = "${bindir} ${base_sbindir}" |
| 51 | DEBIAN_NOAUTONAME:fuse-utils = "1" |
| 52 | DEBIAN_NOAUTONAME:${PN}-dbg = "1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 53 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | do_configure:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 55 | # Make this explicit so overriding base_sbindir propagates properly. |
| 56 | export MOUNT_FUSE_PATH="${base_sbindir}" |
| 57 | } |
| 58 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | do_install:append() { |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 60 | rm -rf ${D}/dev |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | |
| 62 | # systemd class remove the sysv_initddir only if systemd_system_unitdir |
| 63 | # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES |
| 64 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then |
| 65 | rm -rf ${D}${sysconfdir}/init.d/ |
| 66 | fi |
| 67 | |
| 68 | # Install systemd related configuration file |
| 69 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 70 | install -d ${D}${sysconfdir}/modules-load.d |
| 71 | install -m 0644 ${WORKDIR}/fuse.conf ${D}${sysconfdir}/modules-load.d |
| 72 | fi |
| 73 | } |
| 74 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 75 | do_install:append:class-nativesdk() { |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 76 | install -d ${D}${sysconfdir} |
| 77 | mv ${D}/etc/* ${D}${sysconfdir}/ |
| 78 | rmdir ${D}/etc |
| 79 | } |
| 80 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 81 | BBCLASSEXTEND = "native nativesdk" |