Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "ICE: Inter-Client Exchange library" |
| 2 | |
| 3 | DESCRIPTION = "The Inter-Client Exchange (ICE) protocol provides a \ |
| 4 | generic framework for building protocols on top of reliable, byte-stream \ |
| 5 | transport connections. It provides basic mechanisms for setting up and \ |
| 6 | shutting down connections, for performing authentication, for \ |
| 7 | negotiating versions, and for reporting errors. " |
| 8 | |
| 9 | require xorg-lib-common.inc |
| 10 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | LICENSE = "MIT" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d162b1b3c6fa812da9d804dcf8584a93" |
| 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS += "xorgproto xtrans" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | PROVIDES = "ice" |
| 16 | |
| 17 | PE = "1" |
| 18 | |
| 19 | XORG_PN = "libICE" |
| 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 23 | SRC_URI[md5sum] = "76d77499ee7120a56566891ca2c0dbcf" |
| 24 | SRC_URI[sha256sum] = "6f86dce12cf4bcaf5c37dddd8b1b64ed2ddf1ef7b218f22b9942595fb747c348" |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 25 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[arc4] = "ac_cv_lib_bsd_arc4random_buf=yes,ac_cv_lib_bsd_arc4random_buf=no,libbsd" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 28 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |