Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "PNG image format decoding library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "An open source project to develop and maintain the reference \ |
| 3 | library for use in applications that read, create, and manipulate PNG \ |
| 4 | (Portable Network Graphics) raster image files. " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | HOMEPAGE = "http://www.libpng.org/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Libpng" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b0085051bf265bac2bfc38bc89f50000" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 9 | DEPENDS = "zlib" |
| 10 | |
| 11 | LIBV = "16" |
| 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "015e8e15db1eecde5f2eb9eb5b6e59e9" |
| 15 | SRC_URI[sha256sum] = "505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca" |
| 16 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | MIRRORS += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/older-releases/" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | |
| 19 | UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html" |
| 20 | |
| 21 | BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" |
| 22 | |
| 23 | inherit autotools binconfig-disabled pkgconfig |
| 24 | |
| 25 | # Work around missing symbols |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | EXTRA_OECONF:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | |
| 28 | PACKAGES =+ "${PN}-tools" |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 33 | |
| 34 | # CVE-2019-17371 is actually a memory leak in gif2png 2.x |
| 35 | CVE_CHECK_WHITELIST += "CVE-2019-17371" |