blob: c927063f0a34846add3aac6d56cf8f58262be2e7 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
Brad Bishop08902b02019-08-20 09:16:51 -040022 file://posix-shell.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040023"
24
Brad Bishopf3fd2882019-06-21 08:06:37 -040025SRC_URI[md5sum] = "9dcf0aa45d1a42e1b3ca5d39ec7c61a8"
26SRC_URI[sha256sum] = "aa81944e5635de981171772857e72be231a7e0f559ae0292d2737de475383e83"
Brad Bishopc342db32019-05-15 21:57:59 -040027
28inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
29
30PACKAGECONFIG ??= "libidn"
31
32# You must also have CONFIG_SECCOMP enabled in the kernel for
33# seccomp to work.
34PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
35PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
36PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
37PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
38PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
39
40EXTRA_OECONF = " \
41 --enable-doc \
42 --disable-libdane \
43 --disable-guile \
44 --disable-rpath \
45 --enable-local-libopts \
46 --enable-openssl-compatibility \
47 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
Brad Bishop15ae2502019-06-18 21:44:24 -040048 --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \
Brad Bishopc342db32019-05-15 21:57:59 -040049"
50
Brad Bishop08902b02019-08-20 09:16:51 -040051# Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell.
52export POSIX_SHELL="${base_bindir}/sh"
53
Brad Bishopc342db32019-05-15 21:57:59 -040054LDFLAGS_append_libc-musl = " -largp"
55
56do_configure_prepend() {
57 for dir in . lib; do
58 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
59 done
60}
61
62PACKAGES =+ "${PN}-openssl ${PN}-xx"
63
64FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
65FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
66FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
67
68BBCLASSEXTEND = "native nativesdk"