blob: c17a602be8af23bcd55e6f7600b2e8ae1e699ab9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python bindings for the Apache Thrift RPC system"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
4
5SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
6SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
7
8inherit pypi setuptools3
9
10# Use different filename to prevent conflicts with thrift itself
11PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
12
13RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-stringold \
17 ${PYTHON_PN}-threading \
18"
Andrew Geissler69721092021-07-23 12:57:00 -040019
20BBCLASSEXTEND = "native nativesdk"