Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
| 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 12 | " |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | # exclude betas |
| 16 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 17 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 18 | # Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 |
| 19 | # and 4.3.0 doesn't have the issue |
| 20 | CVE_CHECK_WHITELIST += "CVE-2015-7313" |
| 21 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | inherit autotools multilib_header |
| 23 | |
| 24 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 25 | |
| 26 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 27 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 28 | |
| 29 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 30 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 31 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 32 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 33 | |
| 34 | # Convert single-strip uncompressed images to multiple strips of specified |
| 35 | # size (default: 8192) to reduce memory usage |
| 36 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 37 | |
| 38 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 39 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 40 | |
| 41 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 42 | # the tag |
| 43 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 44 | |
| 45 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 46 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 47 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 48 | |
| 49 | PACKAGES =+ "tiffxx tiff-utils" |
| 50 | FILES_tiffxx = "${libdir}/libtiffxx.so.*" |
| 51 | FILES_tiff-utils = "${bindir}/*" |
| 52 | |
| 53 | do_install_append() { |
| 54 | oe_multilib_header tiffconf.h |
| 55 | } |
| 56 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 57 | BBCLASSEXTEND = "native nativesdk" |