Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Boot strap code that the GPU puts on memory to start running the boot loader" |
| 2 | LICENSE = "Proprietary" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://armstub.S;beginline=1;endline=26;md5=9888f34ac06a676129416c952a6a521e" |
| 5 | |
| 6 | inherit deploy nopackages |
| 7 | |
| 8 | include recipes-bsp/common/raspberrypi-tools.inc |
| 9 | |
| 10 | COMPATIBLE_MACHINE = "^rpi$" |
| 11 | |
| 12 | S = "${RPITOOLS_S}/armstubs" |
| 13 | |
| 14 | export CC8="${CC}" |
| 15 | export LD8="${LD}" |
| 16 | export OBJCOPY8="${OBJCOPY}" |
| 17 | export OBJDUMP8="${OBJDUMP} -maarch64" |
| 18 | |
| 19 | do_compile() { |
| 20 | [ -z "${ARMSTUB}" ] && bbfatal "No ARMSTUB defined for your machine." |
| 21 | oe_runmake ${ARMSTUB} |
| 22 | } |
| 23 | |
| 24 | do_deploy() { |
| 25 | install -d ${DEPLOYDIR}/${PN} |
| 26 | cp ${S}/armstub*.bin ${DEPLOYDIR}/${PN} |
| 27 | } |
| 28 | |
| 29 | addtask deploy before do_build after do_install |
| 30 | do_deploy[dirs] += "${DEPLOYDIR}/${PN}" |
| 31 | |
| 32 | PACKAGE_ARCH = "${MACHINE_ARCH}" |