Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Linux NFC daemon" |
| 2 | DESCRIPTION = "A daemon for the Linux Near Field Communication stack" |
| 3 | HOMEPAGE = "http://01.org/linux-nfc" |
| 4 | LICENSE = "GPLv2" |
| 5 | |
| 6 | DEPENDS = "dbus glib-2.0 libnl" |
| 7 | |
| 8 | SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BP}.tar.xz \ |
| 9 | file://neard.in \ |
| 10 | file://Makefile.am-fix-parallel-issue.patch \ |
| 11 | file://Makefile.am-do-not-ship-version.h.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | file://0001-Add-header-dependency-to-nciattach.o.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 13 | " |
| 14 | SRC_URI[md5sum] = "5c691fb7872856dc0d909c298bc8cb41" |
| 15 | SRC_URI[sha256sum] = "eae3b11c541a988ec11ca94b7deab01080cd5b58cfef3ced6ceac9b6e6e65b36" |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ |
| 18 | file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \ |
| 19 | " |
| 20 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 21 | inherit autotools pkgconfig systemd update-rc.d |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 22 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 24 | |
| 25 | PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd" |
| 26 | |
| 27 | EXTRA_OECONF += "--enable-tools" |
| 28 | |
| 29 | # This would copy neard start-stop shell and test scripts |
| 30 | do_install_append() { |
| 31 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 32 | install -d ${D}${sysconfdir}/init.d/ |
| 33 | sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \ |
| 34 | > ${D}${sysconfdir}/init.d/neard |
| 35 | chmod 0755 ${D}${sysconfdir}/init.d/neard |
| 36 | fi |
| 37 | } |
| 38 | |
| 39 | RDEPENDS_${PN} = "dbus" |
| 40 | |
| 41 | # Bluez & Wifi are not mandatory except for handover |
| 42 | RRECOMMENDS_${PN} = "\ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 43 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 44 | ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \ |
| 45 | " |
| 46 | |
| 47 | INITSCRIPT_NAME = "neard" |
| 48 | INITSCRIPT_PARAMS = "defaults 64" |
| 49 | |
| 50 | SYSTEMD_SERVICE_${PN} = "neard.service" |