blob: 44701c8f641ac80e6efab45fd9304701528299a5 [file] [log] [blame]
Kumar Thangavel651d8c42022-06-07 11:09:49 +05301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Patrick Williamsdb126712023-10-24 03:20:31 -05002
Patrick Williams58cf3be2023-10-26 02:38:04 -05003require conf/recipes/fb-consoles.inc
4
Patrick Williamsdb126712023-10-24 03:20:31 -05005# Disable obmc-console ssh ports.
6PACKAGECONFIG:remove = "ssh"
Patrick Williams7c3ee7b2024-02-03 16:52:58 -06007# Remove default config.
8SRC_URI:remove = "file://${BPN}.conf"
Patrick Williamsdb126712023-10-24 03:20:31 -05009
Delphine CC Chiu4072bb42023-07-26 13:38:58 +080010OBMC_BMC_TTY = "ttyS4"
Patrick Williams58cf3be2023-10-26 02:38:04 -050011SERVER_CONFS = "${@ ' '.join([ f'file://server.{i}.conf' for i in d.getVar('OBMC_CONSOLE_TTYS', True).split() ])}"
Delphine CC Chiu4072bb42023-07-26 13:38:58 +080012
Patrick Williams7c3ee7b2024-02-03 16:52:58 -060013SRC_URI:append = " ${SERVER_CONFS}"
Amithash Prasasda6d782d2024-07-12 15:45:04 -070014SRC_URI:append = " file://client.conf "
15
16do_install:append() {
17 install -m 0644 ${WORKDIR}/client.conf ${D}${sysconfdir}/${BPN}/client.conf
18}