Delphine CC Chiu | bed8669 | 2023-02-22 13:17:37 +0800 | [diff] [blame] | 1 | SUMMARY = "Initialize system state" |
| 2 | DESCRIPTION = "Initialize system state" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit pkgconfig |
| 7 | inherit systemd |
| 8 | inherit obmc-phosphor-systemd |
| 9 | |
| 10 | RDEPENDS:${PN} += "bash" |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://greatlakes-system-state-init \ |
| 14 | file://greatlakes-system-state-init@.service \ |
| 15 | " |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${libexecdir}/${PN} |
| 19 | install -m 0755 ${WORKDIR}/greatlakes-system-state-init ${D}${libexecdir}/${PN}/ |
| 20 | } |
| 21 | |
| 22 | TGT = "${SYSTEMD_DEFAULT_TARGET}" |
| 23 | GREATLAKES_SYS_ST_INIT_INSTFMT="../greatlakes-system-state-init@.service:${TGT}.wants/greatlakes-system-state-init@{0}.service" |
| 24 | |
| 25 | SYSTEMD_SERVICE:${PN} += "greatlakes-system-state-init@.service" |
| 26 | SYSTEMD_LINK:${PN} += "${@compose_list(d, 'GREATLAKES_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}" |