Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
Eddie James | b8b4f0c | 2022-05-26 16:47:33 -0500 | [diff] [blame] | 2 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 3 | |
Andrew Jeffery | 096c600 | 2022-08-08 20:48:00 +0930 | [diff] [blame] | 4 | SRC_URI:append:p10bmc = " file://ibm.json file://ips.json file://keys/" |
Eddie James | b8b4f0c | 2022-05-26 16:47:33 -0500 | [diff] [blame] | 5 | SRC_URI:append:p10bmc = " file://p10bmc.cfg" |
Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 6 | |
Andrew Jeffery | 096c600 | 2022-08-08 20:48:00 +0930 | [diff] [blame] | 7 | OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/ibm.json ${WORKDIR}/ips.json" |
Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 8 | OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/" |
| 9 | |
| 10 | # !!! Do not copy p10bmc's use of little-endian key ordering !!! |
| 11 | # |
| 12 | # The prefered order for production silicon is big-endian. Little-endian is necessary for p10bmc |
| 13 | # platforms due to development history involving pre-production AST2600 silicon. More discussion |
| 14 | # here: |
| 15 | # |
| 16 | # https://gerrit.openbmc-project.xyz/c/openbmc/openbmc/+/50716 |
| 17 | SOCSEC_SIGN_EXTRA_OPTS = "--rsa_key_order=little" |
| 18 | |
| 19 | do_deploy:prepend:p10bmc() { |
| 20 | # otptool needs access to the public and private socsec signing keys in the keys/ directory |
| 21 | openssl rsa -in ${SOCSEC_SIGN_KEY} -pubout > ${WORKDIR}/keys/rsa_pub_oem_dss_key.pem |
| 22 | } |