Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "Python library for CSON (schema-compressed JSON)" |
| 5 | HOMEPAGE = "https://github.com/gt3389b/python-cson/" |
| 6 | LICENSE = "MIT" |
| 7 | SECTION = "devel/python" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac" |
| 9 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 10 | PV = "1.0.9+1.0.10" |
| 11 | SRCREV = "69090778bccc5ed124342ba288597fbb2bfa9f39" |
| 12 | SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https \ |
| 13 | file://0001-setup.py-Do-not-poke-at-git-describe-to-find-version.patch" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN}:class-native = "" |
| 18 | DEPENDS:append:class-native = " python-native " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | inherit setuptools3 |
| 21 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 22 | PIP_INSTALL_PACKAGE = "python_cson" |
| 23 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 24 | do_configure:prepend() { |
| 25 | echo "__version__=${PV}" > ${S}/version.py |
| 26 | } |
| 27 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | BBCLASSEXTEND = "native" |
| 29 | |