Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 1 | SUMMARY = "Pure python (i.e. no native extensions) access to Linux IO including I2C and SPI. Drop in replacement for smbus and spidev modules." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PureIO" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2a21fcca821a506d4c36f7bbecc0d009" |
| 5 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | SRC_URI = "git://github.com/adafruit/Adafruit_Python_PureIO.git;branch=main;protocol=https" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 7 | SRCREV = "383b615ce9ff5bbefdf77652799f380016fda353" |
Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 16 | python3-core \ |
| 17 | python3-ctypes \ |
| 18 | python3-fcntl \ |
| 19 | " |