Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Raspberrypi firmware libraries which are required by picamera library" |
| 2 | DESCRIPTION = "Raspberrypi firmware libraries required by picamera library" |
| 3 | LICENSE = "Broadcom-RPi" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://opt/vc/LICENCE;md5=86e53f5f5909ee66900418028de11780" |
| 6 | |
| 7 | include recipes-bsp/common/raspberrypi-firmware.inc |
| 8 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 9 | S = "${WORKDIR}/raspberrypi-firmware-1.${PV}" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | do_install(){ |
| 12 | install -m 0755 -d ${D}${libdir} |
| 13 | install -m 0755 ${S}/opt/vc/lib/*.so ${D}${libdir} |
| 14 | } |
| 15 | |
| 16 | FILES:${PN} = "${libdir}" |
| 17 | |
| 18 | #skipping the QA error since we are directly copying precompiled binaries |
| 19 | INSANE_SKIP:${PN} = "ldflags" |
| 20 | INHIBIT_PACKAGE_STRIP = "1" |
| 21 | INHIBIT_SYSROOT_STRIP = "1" |
| 22 | SOLIBS = ".so" |
| 23 | FILES_SOLIBSDEV = "" |
| 24 | |
| 25 | COMPATIBLE_HOST = "null" |
| 26 | COMPATIBLE_HOST:rpi:libc-glibc = "(arm.*)-linux" |