Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SECTION = "console/network" |
| 2 | SUMMARY = "dhcpcd - a DHCP client" |
| 3 | DESCRIPTION = "dhcpcd runs on your machine and silently configures your \ |
| 4 | computer to work on the attached networks without trouble \ |
| 5 | and mostly without configuration." |
| 6 | |
| 7 | HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/" |
| 8 | |
| 9 | LICENSE = "BSD-2-Clause" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d148485768fe85b9f1072b186a7e9b4d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/" |
| 13 | |
| 14 | SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \ |
| 15 | file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | file://0001-20-resolv.conf-improve-the-sitation-of-working-with-.patch \ |
| 17 | file://0001-privsep-Allow-getrandom-sysctl-for-newer-glibc.patch \ |
| 18 | file://0002-privsep-Allow-newfstatat-syscall-as-well.patch \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 19 | file://0001-privsep-linux-fix-SECCOMP_AUDIT_ARCH-missing-ppc64le.patch \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 20 | file://dhcpcd.service \ |
| 21 | file://dhcpcd@.service \ |
| 22 | " |
| 23 | |
| 24 | SRC_URI[sha256sum] = "819357634efed1ea5cf44ec01b24d3d3f8852fec8b4249925dcc5667c54e376c" |
| 25 | |
| 26 | inherit pkgconfig autotools-brokensep systemd useradd |
| 27 | |
| 28 | SYSTEMD_SERVICE:${PN} = "dhcpcd.service" |
| 29 | |
| 30 | PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 31 | |
| 32 | PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev" |
| 33 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6" |
| 34 | # ntp conflicts with chrony |
| 35 | PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp" |
| 36 | PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony" |
| 37 | PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt" |
| 38 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 39 | # add option to override DBDIR location |
| 40 | DBDIR ?= "${localstatedir}/lib/${BPN}" |
| 41 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 42 | EXTRA_OECONF = "--enable-ipv4 \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 43 | --dbdir=${DBDIR} \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 44 | --sbindir=${base_sbindir} \ |
| 45 | --runstatedir=/run \ |
| 46 | --enable-privsep \ |
| 47 | --privsepuser=dhcpcd \ |
| 48 | --with-hooks \ |
| 49 | --with-eghooks \ |
| 50 | " |
| 51 | |
| 52 | USERADD_PACKAGES = "${PN}" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 53 | USERADD_PARAM:${PN} = "--system -d ${DBDIR} -M -s /bin/false -U dhcpcd" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 54 | |
| 55 | do_install:append () { |
| 56 | # install systemd unit files |
| 57 | install -d ${D}${systemd_system_unitdir} |
| 58 | install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir} |
| 59 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 60 | chmod 700 ${D}${DBDIR} |
| 61 | chown dhcpcd:dhcpcd ${D}${DBDIR} |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 62 | } |
| 63 | |
| 64 | FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug" |