Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "An implementation of the GEIS interface" |
| 2 | DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \ |
| 3 | interface\ |
| 4 | GEIS is a library for applications and toolkit programmers which \ |
| 5 | provides a consistent platform independent interface for any \ |
| 6 | system-wide input gesture recognition mechanism." |
| 7 | |
| 8 | HOMEPAGE = "https://launchpad.net/geis" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-3.0-only & LGPL-3.0-only" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = " \ |
| 12 | file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
| 13 | file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| 14 | " |
| 15 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 16 | inherit autotools pkgconfig python3native lib_package features_check |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 18 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | |
| 20 | DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame" |
| 21 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | file://fix-indentation-for-gcc6.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | file://0001-libgeis-Compare-the-first-character-of-string-to-nul.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 25 | file://0001-provide-function-declaration-with-prototypes.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | |
| 28 | UPSTREAM_CHECK_URI = "https://launchpad.net/geis/trunk" |
| 29 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf" |
| 31 | SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb" |
| 32 | |
| 33 | EXTRA_OECONF = "--disable-integration-tests" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | FILES:${PN}-bin = "${bindir}" |
| 36 | RDEPENDS:${PN}-bin = " \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 37 | python3-compression \ |
| 38 | python3-core \ |
| 39 | python3-crypt \ |
| 40 | python3-ctypes \ |
| 41 | python3-fcntl \ |
| 42 | python3-misc \ |
| 43 | python3-pickle \ |
| 44 | python3-shell \ |
| 45 | python3-stringold \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | python3-threading \ |
| 47 | " |
| 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | FILES:${PN} += " \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 50 | ${datadir}/geisview \ |
| 51 | ${libdir}/${PYTHON_DIR}/site-packages/geis* \ |
| 52 | ${libdir}/${PYTHON_DIR}/site-packages/_*.so \ |
| 53 | " |
| 54 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 55 | FILES:${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 56 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 57 | FILES:${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 58 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | FILES:${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a" |