Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 1 | SUMMARY = "high level C++ wrapper for rdkafka" |
| 2 | DESCRIPTION = "cppkafka allows C++ applications to consume and produce messages using the Apache Kafka protocol." |
| 3 | HOMEPAGE = "https://github.com/mfontanini/cppkafka" |
| 4 | SECTION = "lib" |
| 5 | LICENSE = "BSD-2-Clause" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://LICENSE;md5=d8b4ca15d239dc1485ef495c8f1bcc72 \ |
| 9 | " |
| 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/mfontanini/cppkafka;protocol=https;branch=master \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | " |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 13 | SRCREV = "91ac543cbd2228588dcf24a6ca357f8be0f4e5ab" |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 14 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 15 | BASEPV = "0.4.0" |
| 16 | PV = "${BASEPV}+git" |
| 17 | |
| 18 | DEPENDS = "librdkafka curl boost chrpath-replacement-native" |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 19 | |
| 20 | inherit cmake |
| 21 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 22 | EXTRA_OECMAKE = "-DCPPKAFKA_BUILD_SHARED=ON" |
| 23 | |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | do_install:append(){ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 27 | chrpath -d ${D}${libdir}/libcppkafka.so.${BASEPV} |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 28 | sed -i -e 's|${STAGING_INCDIR}|\$\{includedir\}|g' ${D}${datadir}/pkgconfig/cppkafka.pc |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 29 | } |