Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for controlling team network device" |
| 2 | HOMEPAGE = "http://www.libteam.org/" |
| 3 | SECTION = "libs/network" |
| 4 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 7 | |
| 8 | DEPENDS = "libnl libdaemon jansson" |
| 9 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
| 12 | file://0002-teamd-Re-adjust-include-header-order.patch \ |
| 13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | file://0001-team_basic_test.py-switch-to-python3.patch \ |
| 15 | file://0001-team_basic_test.py-check-the-return-value.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | file://0001-teamd-Include-missing-headers-for-strrchr-and-memcmp.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://run-ptest \ |
| 18 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 19 | SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools pkgconfig ptest |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN} = "${libdir}/libteam${SOLIBS} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | PACKAGES += "${PN}-dctl ${PN}-utils" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | FILES:${PN}-utils = "${bindir}/bond2team \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | ${bindir}/teamd \ |
| 33 | ${bindir}/teamdctl \ |
| 34 | ${bindir}/teamnl \ |
| 35 | " |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | RDEPENDS:${PN}-utils = "bash" |
| 38 | RDEPENDS:${PN}-ptest = "python3-core" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
| 40 | do_install_ptest() { |
| 41 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ |
| 42 | } |