Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A small network printer daemon for embedded situations that passes the job directly to the printer" |
| 2 | HOMEPAGE = "http://p910nd.sourceforge.net/" |
| 3 | SECTION = "console/utils" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3d82780e8917b360cbee7b9ec3e40734" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
| 7 | PR = "r2" |
| 8 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 9 | # v0.97 |
| 10 | SRCREV = "57ebc07ad8723ea4106090536c58c7f7160743e2" |
| 11 | SRC_URI = "git://github.com/kenyapcomau/p910nd;protocol=https;branch=master \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | file://fix-var-lock.patch" |
| 13 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit update-rc.d |
| 17 | |
| 18 | INITSCRIPT_NAME = "p910nd" |
| 19 | INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ." |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
| 21 | do_compile () { |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 22 | ${CC} ${CFLAGS} ${LDFLAGS} -o p910nd p910nd.c |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | } |
| 24 | |
| 25 | do_install () { |
| 26 | install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 27 | install -D -m 0644 ${S}/aux/p910nd.conf ${D}${sysconfdir}/sysconfig/p910nd.conf |
| 28 | install -D -m 0644 ${S}/aux/p910nd.init ${D}${sysconfdir}/init.d/p910nd |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | } |