Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A Python generic test automation framework" |
| 2 | DESCRIPTION = "Generic open source test atomation framework for acceptance\ |
| 3 | testing and acceptance test-driven development (ATDD). It has easy-to-use\ |
| 4 | tabular test data syntax and it utilizes the keyword-driven testing approach.\ |
| 5 | Its testing capabilities can be extended by test libraries implemented either\ |
| 6 | with Python or Java, and users can create new higher-level keywords from\ |
| 7 | existing ones using the same syntax that is used for creating test cases." |
| 8 | HOMEPAGE = "http://robotframework.org" |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | PYPI_PACKAGE_EXT = "zip" |
| 15 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "04623f758346c917db182e17591ffa474090560c02ed5a64343902e72b7b4bd5" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 17 | |
| 18 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 19 | python3-shell \ |
| 20 | python3-pprint \ |
| 21 | python3-xml \ |
| 22 | python3-difflib \ |
| 23 | python3-threading \ |
| 24 | python3-html \ |
| 25 | python3-docutils \ |
| 26 | python3-ctypes \ |
| 27 | python3-logging \ |
| 28 | python3-numbers \ |
| 29 | python3-profile \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 30 | " |