blob: beb71e6a188e709513a699d934e06d222ecbd4a7 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14PYPI_PACKAGE_EXT = "zip"
15
Patrick Williams73bd93f2024-02-20 08:07:48 -060016SRC_URI[sha256sum] = "04623f758346c917db182e17591ffa474090560c02ed5a64343902e72b7b4bd5"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
18RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060019 python3-shell \
20 python3-pprint \
21 python3-xml \
22 python3-difflib \
23 python3-threading \
24 python3-html \
25 python3-docutils \
26 python3-ctypes \
27 python3-logging \
28 python3-numbers \
29 python3-profile \
Andrew Geissler9aee5002022-03-30 16:27:02 +000030"