Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "XFt: X FreeType libary" |
| 2 | |
| 3 | DESCRIPTION = "Xft was designed to provide good support for scalable \ |
| 4 | fonts, and to do so efficiently. Unlike the core fonts system, it \ |
| 5 | supports features such as anti-aliasing and sub-pixel rasterisation. \ |
| 6 | Perhaps more importantly, it gives applications full control over the \ |
| 7 | way glyphs are rendered, making fine typesetting and WYSIWIG display \ |
| 8 | possible. Finally, it allows applications to use fonts that are not \ |
| 9 | installed system-wide for displaying documents with embedded fonts. Xft \ |
| 10 | is not compatible with the core fonts system: usage of Xft requires \ |
| 11 | fairly extensive changes to toolkits (user-interface libraries)." |
| 12 | |
| 13 | require xorg-lib-common.inc |
| 14 | |
| 15 | LICENSE = "MIT" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=90b90b60eb30f65fc9c2673d7cf59e24" |
| 17 | |
| 18 | DEPENDS += "virtual/libx11 libxrender freetype fontconfig" |
| 19 | PROVIDES = "xft" |
| 20 | |
| 21 | PE = "1" |
| 22 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 23 | SRC_URI[sha256sum] = "5e8c3c4bc2d4c0a40aef6b4b38ed2fb74301640da29f6528154b5009b1c6dd49" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 24 | |
| 25 | XORG_PN = "libXft" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
| 29 | python populate_packages:prepend () { |
| 30 | if d.getVar('DEBIAN_NAMES'): |
| 31 | d.setVar('PKG:${PN}', '${MLPREFIX}libxft2') |
| 32 | } |