Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Cherokee Web Server fast and secure" |
| 2 | SUMMARY_cget = "Small downloader based in the Cherokee client library" |
| 3 | HOMEPAGE = "http://www.cherokee-project.com/" |
| 4 | SECTION = "network" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 7 | |
| 8 | DEPENDS = "unzip-native libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 9 | |
| 10 | SRCREV = "75f041e2255e6dd0692db2f14611c2647dbe8425" |
| 11 | PV = "1.2.104+git${SRCPV}" |
| 12 | SRC_URI = "git://github.com/cherokee/webserver \ |
| 13 | file://cherokee.init \ |
| 14 | file://cherokee.service \ |
| 15 | file://cherokee-install-configured.py-once.patch \ |
| 16 | file://0001-configure.ac-Add-foreign-to-AM_INIT_AUTOMAKE.patch \ |
| 17 | file://0001-make-Do-not-build-po-files.patch \ |
| 18 | " |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd pythonnative |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 25 | PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav" |
| 26 | PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap" |
| 27 | PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip" |
| 28 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 29 | |
| 30 | EXTRA_OECONF = "--disable-static \ |
| 31 | --disable-nls \ |
| 32 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ |
| 33 | --with-wwwroot=${localstatedir}/www/cherokee \ |
| 34 | " |
| 35 | |
| 36 | do_install_append () { |
| 37 | install -m 0755 -d ${D}${sysconfdir}/init.d |
| 38 | install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee |
| 39 | |
| 40 | # clean up .la files for plugins |
| 41 | rm -f ${D}${libdir}/cherokee/*.la |
| 42 | |
| 43 | install -d ${D}${systemd_unitdir}/system |
| 44 | install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system |
| 45 | rmdir "${D}${localstatedir}/run" |
| 46 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
| 47 | } |
| 48 | |
| 49 | # Put -dev near the front so we can move the .la files into it with a wildcard |
| 50 | PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget" |
| 51 | |
| 52 | FILES_cget = "${bindir}/cget" |
| 53 | FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}" |
| 54 | FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}" |
| 55 | FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}" |
| 56 | |
| 57 | # Pack the htdocs |
| 58 | FILES_${PN} += "${localstatedir}/www/cherokee" |
| 59 | |
| 60 | CONFFILES_${PN} = " \ |
| 61 | ${sysconfdir}/cherokee/cherokee.conf \ |
| 62 | ${sysconfdir}/init.d/cherokee \ |
| 63 | " |
| 64 | |
| 65 | INITSCRIPT_NAME = "cherokee" |
| 66 | INITSCRIPT_PARAMS = "defaults 91 91" |
| 67 | |
| 68 | RPROVIDES_${PN} += "${PN}-systemd" |
| 69 | RREPLACES_${PN} += "${PN}-systemd" |
| 70 | RCONFLICTS_${PN} += "${PN}-systemd" |
| 71 | SYSTEMD_SERVICE_${PN} = "cherokee.service" |