George Hung | ce97fb1 | 2020-05-13 17:25:22 +0800 | [diff] [blame] | 1 | SUMMARY = "OpenBMC Quanta Boot Status LED Service" |
| 2 | DESCRIPTION = "OpenBMC Quanta Boot Status LED Daemon." |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
| 10 | RDEPENDS_${PN} += "bash" |
| 11 | |
| 12 | SRC_URI = " file://boot-status-led.sh \ |
| 13 | file://boot-status-led.service \ |
| 14 | " |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${bindir} |
| 18 | install -m 0755 ${WORKDIR}/boot-status-led.sh ${D}${bindir}/ |
| 19 | |
| 20 | install -d ${D}${systemd_system_unitdir} |
| 21 | install -m 0644 ${WORKDIR}/boot-status-led.service ${D}${systemd_system_unitdir} |
| 22 | } |
| 23 | |
| 24 | SYSTEMD_PACKAGES = "${PN}" |
| 25 | SYSTEMD_SERVICE_${PN} = "boot-status-led.service" |