blob: aed95cdaa47d46d946a209957d1d7c806c2dea1b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "LINPACK Benchmarks are a measure of a system's floating point computing power"
2SUMMARY = "LINPACK is a software library for performing numerical linear algebra on digital computers"
3
4LICENSE = "PD"
5LIC_FILES_CHKSUM ="file://${WORKDIR}/linpacknew.c;beginline=1;endline=23;md5=aa025e3bc44190c71e4c5e3b084fed87"
6
7SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c"
8SRC_URI[md5sum] = "1c5d0b6a31264685d2e651c920e3cdf4"
9SRC_URI[sha256sum] = "a63f2ec86512959f1fd926bfafb85905b2d7b7402942ffae3af374d48745e97e"
10
11S = "${WORKDIR}"
12
13do_compile () {
14 ${CC} ${CFLAGS} ${LDFLAGS} -o linpack linpacknew.c -lm
15}
16
17do_install () {
18 install -Dm 0755 linpack ${D}${bindir}/linpack
19}
20