blob: 8bb89f418ce72343bcca99d9c67cb1a61884dd7e [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Persistent Memory Development Kit"
2DESCRIPTION = "Persistent Memory Development Kit"
3HOMEPAGE = "http://pmem.io"
4SECTION = "libs"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LICENSE = "BSD-3-Clause"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=b44ee63f162f9cdb18fff1224877aafd"
Brad Bishop26bdd442019-08-16 17:08:17 -04007DEPENDS = "ndctl"
8
9# Required to have the fts.h header for musl
10DEPENDS_append_libc-musl = " fts"
11
12S = "${WORKDIR}/git"
13
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050014SRC_URI = "git://github.com/pmem/pmdk.git"
Brad Bishop26bdd442019-08-16 17:08:17 -040015
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050016SRCREV = "1926ffb8f3f5f0617b3b3ed32029d437c272f187"
Brad Bishop26bdd442019-08-16 17:08:17 -040017
18inherit autotools-brokensep pkgconfig
19
20# Fix jemalloc error:
21# | configure: error: cannot run C compiled programs.
22# | If you meant to cross compile, use `--host'.
23#
24# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050025EXTRA_OEMAKE = "BUILD_EXAMPLES='n' DOC='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
Brad Bishop26bdd442019-08-16 17:08:17 -040026
27# Fix the missing fts libs when using musl
28EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"
29
Andrew Geissler7f40b712020-05-15 14:09:53 -050030do_configure_prepend() {
31 touch .skip-doc
32}
33
Brad Bishop26bdd442019-08-16 17:08:17 -040034do_install() {
35 oe_runmake prefix=${prefix} DESTDIR=${D} install
36
37 # Remove uneeded files
38 rm -rf ${D}/usr/${baselib}/pmdk_debug
39}
40
41# Include these by default otherwise the SDK is not very useful
42FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio"
43FILES_${PN} += "${libdir}/*so*"
44FILES_${PN} += "${libdir}/pkgconfig/*.pc"
45FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/"
46FILES_${PN} += "/usr/etc"
47FILES_${PN} += "/usr/share"
48
49COMPATIBLE_HOST='(x86_64).*'