Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Remote file distribution client and server" |
| 2 | DESCRIPTION = "\ |
| 3 | Rdist is a program to maintain identical copies of files over multiple \ |
| 4 | hosts. It preserves the owner, group, mode, and mtime of files if \ |
| 5 | possible and can update programs that are executing. \ |
| 6 | " |
| 7 | SECTION = "console/network" |
| 8 | LICENSE = "BSD-4-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://Copyright;md5=3f47ec9f64b11c8192ee05a66b5c2755" |
| 10 | |
| 11 | SRC_URI = "http://www.magnicomp.com/download/${BPN}/${BP}.tar.gz" |
| 12 | SRC_URI[md5sum] = "546779700af70aa5f9103e08782cdcac" |
| 13 | SRC_URI[sha256sum] = "2bb0d0f5904eadc9e7fe3d60c15389d6897fcf884211070e289a6c710ff37f96" |
| 14 | |
| 15 | SRC_URI += "file://rdist-6.1.5-linux.patch \ |
| 16 | file://rdist-6.1.5-links.patch \ |
| 17 | file://rdist-6.1.5-oldpath.patch \ |
| 18 | file://rdist-6.1.5-hardlink.patch \ |
| 19 | file://rdist-6.1.5-bison.patch \ |
| 20 | file://rdist-6.1.5-varargs.patch \ |
| 21 | file://rdist-6.1.5-maxargs.patch \ |
| 22 | file://rdist-6.1.5-lfs.patch \ |
| 23 | file://rdist-6.1.5-cleanup.patch \ |
| 24 | file://rdist-6.1.5-svr4.patch \ |
| 25 | file://rdist-6.1.5-ssh.patch \ |
| 26 | file://rdist-6.1.5-mkstemp.patch \ |
| 27 | file://rdist-6.1.5-stat64.patch \ |
| 28 | file://rdist-6.1.5-fix-msgsndnotify-loop.patch \ |
| 29 | file://rdist-6.1.5-bb-build.patch \ |
| 30 | file://rdist-6.1.5-makefile-add-ldflags.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 31 | file://rdist-6.1.5-fix-parallel-build.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 32 | " |
| 33 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/rdist/files/rdist/" |
| 35 | UPSTREAM_CHECK_REGEX = "/rdist/(?P<pver>\d+(\.\d+)+)" |
| 36 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | DEPENDS = "bison-native" |
| 38 | |
| 39 | inherit autotools-brokensep |
| 40 | |
| 41 | EXTRA_OEMAKE = "BIN_GROUP=root MAN_GROUP=root RDIST_MODE=755 RDISTD_MODE=755 MAN_MODE=644" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 42 | |
| 43 | # http://errors.yoctoproject.org/Errors/Details/186972/ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | COMPATIBLE_HOST:libc-musl = 'null' |