Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Wi-Fi Test Suite Linux Control Agent" |
| 2 | DESCRIPTION = "Wi-Fi Test Suite is a software platform originally developed \ |
| 3 | by Wi-Fi Alliance, the global non-profit industry association that brings you \ |
| 4 | Wi-Fi, to support certification program development and device certification." |
| 5 | HOMEPAGE = "https://www.wi-fi.org/certification/wi-fi-test-suite" |
| 6 | LICENSE = "ISC" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=0542427ed5c315ca34aa09ae7a85ed32" |
| 8 | SECTION = "test" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 11 | SRCREV = "2da947374c8324f88a0e2155aeba4cf75464b0d8" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | SRC_URI = "git://github.com/Wi-FiTestSuite/Wi-FiTestSuite-Linux-DUT.git \ |
| 13 | file://0001-Use-toolchain-from-environment-variables.patch \ |
| 14 | file://0002-Add-missing-include-removes-unnedded-stuff-and-add-n.patch \ |
| 15 | file://0003-fix-path-to-usr-sbin-for-script-and-make-script-for-.patch \ |
| 16 | file://0004-run-ranlib-per-library-and-use-AR.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 17 | file://fno-common.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | # to avoid host path QA error |
| 21 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
| 22 | # Fix GNU HASH error |
| 23 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 24 | |
| 25 | do_install () { |
| 26 | install -d ${D}${libdir} |
| 27 | install -m 0644 ${S}/lib/libwfa.a ${D}${libdir} |
| 28 | install -m 0644 ${S}/lib/libwfa_ca.a ${D}${libdir} |
| 29 | install -m 0644 ${S}/lib/libwfa_dut.a ${D}${libdir} |
| 30 | install -d ${D}${sbindir} |
| 31 | install -m 0755 ${S}/dut/wfa_dut ${D}${sbindir} |
| 32 | install -m 0755 ${S}/ca/wfa_ca ${D}${sbindir} |
| 33 | install -m 0755 ${S}/scripts/*.sh ${D}${sbindir} |
| 34 | install -m 0755 ${S}/scripts/arp_neigh_loop ${D}${sbindir} |
| 35 | install -m 0755 ${S}/scripts/dev_send_frame ${D}${sbindir} |
| 36 | install -m 0755 ${S}/scripts/sta_reset_parm ${D}${sbindir} |
| 37 | } |
| 38 | |
| 39 | RDEPENDS_${PN} = "wpa-supplicant" |