blob: ee08c12beeae617fbce44d4728cd17fc0742a57d [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
Brad Bishop08902b02019-08-20 09:16:51 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=e11f5c3149cdec4bb309babb020b32b9 \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
Brad Bishopc342db32019-05-15 21:57:59 -04009
Brad Bishop08902b02019-08-20 09:16:51 -040010SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.xz"
Brad Bishop6dbb3162019-11-25 09:41:34 -050011SRC_URI[md5sum] = "2b3a4dfdb3e5e50055f941978944da9f"
12SRC_URI[sha256sum] = "9413b8d96132d699687ef914ebb8c50440efc87b3f775d25856d7ec347c03c12"
Brad Bishopc342db32019-05-15 21:57:59 -040013
14inherit autotools pkgconfig lib_package gtk-doc
15
Brad Bishopf3f93bb2019-10-16 14:33:32 -040016PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
17PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo"
18PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig"
19PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype"
20PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
Brad Bishop79641f22019-09-10 07:20:22 -040021PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040022PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
Brad Bishopc342db32019-05-15 21:57:59 -040023
Brad Bishop1d80a2e2019-11-15 16:35:03 -050024PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
Brad Bishopc342db32019-05-15 21:57:59 -040025
26LEAD_SONAME = "libharfbuzz.so"
27
Brad Bishopf3f93bb2019-10-16 14:33:32 -040028do_install_append() {
29 # If no tools are installed due to PACKAGECONFIG then this directory is
30 #still installed, so remove it to stop packaging wanings.
31 rmdir --ignore-fail-on-non-empty ${D}${bindir}
32}
33
Brad Bishopc342db32019-05-15 21:57:59 -040034FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
35FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
36 ${libdir}/libharfbuzz-icu.so \
37 ${libdir}/pkgconfig/harfbuzz-icu.pc \
38"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050039FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
Brad Bishopc342db32019-05-15 21:57:59 -040040
41BBCLASSEXTEND = "native nativesdk"