blob: b3bf2029d3659e5eb41d5f1335d1b6f0fdb3234d [file] [log] [blame]
Patrick Williamse69d2352017-02-23 20:56:04 -06001SUMMARY = "Native Linux KVM tool"
2DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
6
7DEPENDS = "dtc libaio zlib"
8
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \
10 file://external-crosscompiler.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 file://0001-Avoid-pointers-for-address-of-packed-members.patch \
12 "
Patrick Williamse69d2352017-02-23 20:56:04 -060013
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014SRCREV = "3fea89a924511f9f8fe05a892098fad77c1eca0d"
Patrick Williamse69d2352017-02-23 20:56:04 -060015PV = "3.18.0+git${SRCREV}"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE='ARCH="${TARGET_ARCH}" V=1'
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 ${S}/lkvm ${D}${bindir}/
24}