Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame] | 1 | SUMMARY = "Native Linux KVM tool" |
| 2 | DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests." |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 6 | |
| 7 | DEPENDS = "dtc libaio zlib" |
| 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \ |
| 10 | file://external-crosscompiler.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 11 | file://0001-Avoid-pointers-for-address-of-packed-members.patch \ |
| 12 | " |
Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame] | 13 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 14 | SRCREV = "3fea89a924511f9f8fe05a892098fad77c1eca0d" |
Patrick Williams | e69d235 | 2017-02-23 20:56:04 -0600 | [diff] [blame] | 15 | PV = "3.18.0+git${SRCREV}" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | EXTRA_OEMAKE='ARCH="${TARGET_ARCH}" V=1' |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 ${S}/lkvm ${D}${bindir}/ |
| 24 | } |