blob: 12df88f8c4f4822983f48fa6c317859bf4c7b979 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001BUILD_GOOS = "${@go_map_os(d.getVar('BUILD_OS', True), d)}"
2BUILD_GOARCH = "${@go_map_arch(d.getVar('BUILD_ARCH', True), d)}"
3BUILD_GOTUPLE = "${BUILD_GOOS}_${BUILD_GOARCH}"
4HOST_GOOS = "${@go_map_os(d.getVar('HOST_OS', True), d)}"
5HOST_GOARCH = "${@go_map_arch(d.getVar('HOST_ARCH', True), d)}"
6HOST_GOARM = "${@go_map_arm(d.getVar('HOST_ARCH', True), d.getVar('TUNE_FEATURES', True), d)}"
7HOST_GOTUPLE = "${HOST_GOOS}_${HOST_GOARCH}"
8TARGET_GOOS = "${@go_map_os(d.getVar('TARGET_OS', True), d)}"
9TARGET_GOARCH = "${@go_map_arch(d.getVar('TARGET_ARCH', True), d)}"
10TARGET_GOARM = "${@go_map_arm(d.getVar('TARGET_ARCH', True), d.getVar('TUNE_FEATURES', True), d)}"
11TARGET_GOTUPLE = "${TARGET_GOOS}_${TARGET_GOARCH}"
12GO_BUILD_BINDIR = "${@['bin/${HOST_GOTUPLE}','bin'][d.getVar('BUILD_GOTUPLE',True) == d.getVar('HOST_GOTUPLE',True)]}"
13
14def go_map_arch(a, d):
15 import re
16 if re.match('i.86', a):
17 return '386'
18 elif a == 'x86_64':
19 return 'amd64'
20 elif re.match('arm.*', a):
21 return 'arm'
22 elif re.match('aarch64.*', a):
23 return 'arm64'
24 elif re.match('mips64el*', a):
25 return 'mips64le'
26 elif re.match('mips64*', a):
27 return 'mips64'
28 elif re.match('mipsel*', a):
29 return 'mipsle'
30 elif re.match('mips*', a):
31 return 'mips'
32 elif re.match('p(pc|owerpc)(64)', a):
33 return 'ppc64'
34 elif re.match('p(pc|owerpc)(64el)', a):
35 return 'ppc64le'
36 else:
37 raise bb.parse.SkipPackage("Unsupported CPU architecture: %s" % a)
38
39def go_map_arm(a, f, d):
40 import re
41 if re.match('arm.*', a):
42 if 'armv7' in f:
43 return '7'
44 elif 'armv6' in f:
45 return '6'
46 return ''
47
48def go_map_os(o, d):
49 if o.startswith('linux'):
50 return 'linux'
51 return o
52
53