Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # grub-efi.bbclass |
| 2 | # Copyright (c) 2011, Intel Corporation. |
| 3 | # All rights reserved. |
| 4 | # |
| 5 | # Released under the MIT license (see packages/COPYING) |
| 6 | |
| 7 | # Provide grub-efi specific functions for building bootable images. |
| 8 | |
| 9 | # External variables |
| 10 | # ${INITRD} - indicates a list of filesystem images to concatenate and use as an initrd (optional) |
| 11 | # ${ROOTFS} - indicates a filesystem image to include as the root filesystem (optional) |
| 12 | # ${GRUB_GFXSERIAL} - set this to 1 to have graphics and serial in the boot menu |
| 13 | # ${LABELS} - a list of targets for the automatic config |
| 14 | # ${APPEND} - an override list of append strings for each label |
| 15 | # ${GRUB_OPTS} - additional options to add to the config, ';' delimited # (optional) |
| 16 | # ${GRUB_TIMEOUT} - timeout before executing the deault label (optional) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 17 | # ${GRUB_ROOT} - grub's root device. |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | do_bootimg[depends] += "${MLPREFIX}grub-efi:do_deploy" |
| 20 | do_bootdirectdisk[depends] += "${MLPREFIX}grub-efi:do_deploy" |
| 21 | |
| 22 | GRUB_SERIAL ?= "console=ttyS0,115200" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 23 | GRUB_CFG_VM = "${S}/grub_vm.cfg" |
| 24 | GRUB_CFG_LIVE = "${S}/grub_live.cfg" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | GRUB_TIMEOUT ?= "10" |
| 26 | #FIXME: build this from the machine config |
| 27 | GRUB_OPTS ?= "serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1" |
| 28 | |
| 29 | EFIDIR = "/EFI/BOOT" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 30 | GRUB_ROOT ?= "${ROOT}" |
| 31 | APPEND ?= "" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | |
| 33 | # Need UUID utility code. |
| 34 | inherit fs-uuid |
| 35 | |
| 36 | efi_populate() { |
| 37 | # DEST must be the root of the image so that EFIDIR is not |
| 38 | # nested under a top level directory. |
| 39 | DEST=$1 |
| 40 | |
| 41 | install -d ${DEST}${EFIDIR} |
| 42 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 43 | GRUB_IMAGE="grub-efi-bootia32.efi" |
| 44 | DEST_IMAGE="bootia32.efi" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 45 | if [ "${TARGET_ARCH}" = "x86_64" ]; then |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 46 | GRUB_IMAGE="grub-efi-bootx64.efi" |
| 47 | DEST_IMAGE="bootx64.efi" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 49 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${GRUB_IMAGE} ${DEST}${EFIDIR}/${DEST_IMAGE} |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 50 | EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 51 | printf 'fs0:%s\%s\n' "$EFIPATH" "$DEST_IMAGE" >${DEST}/startup.nsh |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 52 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 53 | install -m 0644 ${GRUB_CFG} ${DEST}${EFIDIR}/grub.cfg |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 54 | } |
| 55 | |
| 56 | efi_iso_populate() { |
| 57 | iso_dir=$1 |
| 58 | efi_populate $iso_dir |
| 59 | # Build a EFI directory to create efi.img |
| 60 | mkdir -p ${EFIIMGDIR}/${EFIDIR} |
| 61 | cp $iso_dir/${EFIDIR}/* ${EFIIMGDIR}${EFIDIR} |
| 62 | cp $iso_dir/vmlinuz ${EFIIMGDIR} |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 63 | EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 64 | printf 'fs0:%s\%s\n' "$EFIPATH" "$GRUB_IMAGE" > ${EFIIMGDIR}/startup.nsh |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 65 | if [ -f "$iso_dir/initrd" ] ; then |
| 66 | cp $iso_dir/initrd ${EFIIMGDIR} |
| 67 | fi |
| 68 | } |
| 69 | |
| 70 | efi_hddimg_populate() { |
| 71 | efi_populate $1 |
| 72 | } |
| 73 | |
| 74 | python build_efi_cfg() { |
| 75 | import sys |
| 76 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 77 | workdir = d.getVar('WORKDIR') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 78 | if not workdir: |
| 79 | bb.error("WORKDIR not defined, unable to package") |
| 80 | return |
| 81 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 82 | gfxserial = d.getVar('GRUB_GFXSERIAL') or "" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 83 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 84 | labels = d.getVar('LABELS') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 85 | if not labels: |
| 86 | bb.debug(1, "LABELS not defined, nothing to do") |
| 87 | return |
| 88 | |
| 89 | if labels == []: |
| 90 | bb.debug(1, "No labels, nothing to do") |
| 91 | return |
| 92 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 93 | cfile = d.getVar('GRUB_CFG') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 94 | if not cfile: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 95 | bb.fatal('Unable to read GRUB_CFG') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 96 | |
| 97 | try: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 98 | cfgfile = open(cfile, 'w') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 99 | except OSError: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 100 | bb.fatal('Unable to open %s' % cfile) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 101 | |
| 102 | cfgfile.write('# Automatically created by OE\n') |
| 103 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 104 | opts = d.getVar('GRUB_OPTS') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 105 | if opts: |
| 106 | for opt in opts.split(';'): |
| 107 | cfgfile.write('%s\n' % opt) |
| 108 | |
| 109 | cfgfile.write('default=%s\n' % (labels.split()[0])) |
| 110 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 111 | timeout = d.getVar('GRUB_TIMEOUT') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 112 | if timeout: |
| 113 | cfgfile.write('timeout=%s\n' % timeout) |
| 114 | else: |
| 115 | cfgfile.write('timeout=50\n') |
| 116 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 117 | root = d.getVar('GRUB_ROOT') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 118 | if not root: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 119 | bb.fatal('GRUB_ROOT not defined') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 120 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 121 | if gfxserial == "1": |
| 122 | btypes = [ [ " graphics console", "" ], |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 123 | [ " serial console", d.getVar('GRUB_SERIAL') or "" ] ] |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 124 | else: |
| 125 | btypes = [ [ "", "" ] ] |
| 126 | |
| 127 | for label in labels.split(): |
| 128 | localdata = d.createCopy() |
| 129 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 130 | overrides = localdata.getVar('OVERRIDES') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 131 | if not overrides: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 132 | bb.fatal('OVERRIDES not defined') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 133 | |
| 134 | for btype in btypes: |
| 135 | localdata.setVar('OVERRIDES', label + ':' + overrides) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 136 | |
| 137 | cfgfile.write('\nmenuentry \'%s%s\'{\n' % (label, btype[0])) |
| 138 | lb = label |
| 139 | if label == "install": |
| 140 | lb = "install-efi" |
| 141 | cfgfile.write('linux /vmlinuz LABEL=%s' % (lb)) |
| 142 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 143 | cfgfile.write(' %s' % replace_rootfs_uuid(d, root)) |
| 144 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 145 | append = localdata.getVar('APPEND') |
| 146 | initrd = localdata.getVar('INITRD') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 147 | |
| 148 | if append: |
| 149 | append = replace_rootfs_uuid(d, append) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 150 | cfgfile.write(' %s' % (append)) |
| 151 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 152 | cfgfile.write(' %s' % btype[1]) |
| 153 | cfgfile.write('\n') |
| 154 | |
| 155 | if initrd: |
| 156 | cfgfile.write('initrd /initrd') |
| 157 | cfgfile.write('\n}\n') |
| 158 | |
| 159 | cfgfile.close() |
| 160 | } |