blob: a642d7cf5d07a18bd8331d89d884f3afc70f5b5f [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
Andrew Geisslerd5838332022-05-27 11:33:10 -05009SRC_URI = "\
Andrew Geissler615f2f12022-07-15 14:00:58 -050010 git://github.com/bats-core/bats-core.git;branch=master;protocol=https \
Andrew Geisslerd5838332022-05-27 11:33:10 -050011 "
12
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050013# v1.9.0
14SRCREV = "6636e2c2ef5ffe361535cb45fc61682c5ef46b71"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16S = "${WORKDIR}/git"
17
18do_configure:prepend() {
19 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats
20 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file
21 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test
22}
23
24do_install() {
25 # Just a bunch of bash scripts to install
26 ${S}/install.sh ${D}${prefix} ${baselib}
27}
28
29RDEPENDS:${PN} = "bash"
30FILES:${PN} += "${libdir}/bats-core/*"
31
32PACKAGECONFIG ??= "pretty"
33PACKAGECONFIG[pretty] = ",,,ncurses"