blob: 628a7cbd8252cb4b56646d45ba05a9319a170a2b [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001KBRANCH ?= "v6.6/standard/tiny/base"
Andrew Geissler220dafd2023-10-04 10:18:08 -05002
3LINUX_KERNEL_TYPE = "tiny"
4KCONFIG_MODE = "--allnoconfig"
5
6require recipes-kernel/linux/linux-yocto.inc
7
8# CVE exclusions
Patrick Williams169d7bc2024-01-05 11:33:25 -06009include recipes-kernel/linux/cve-exclusion_6.6.inc
Andrew Geissler220dafd2023-10-04 10:18:08 -050010
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060011LINUX_VERSION ?= "6.6.12"
Andrew Geissler220dafd2023-10-04 10:18:08 -050012LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13
14DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
15DEPENDS += "openssl-native util-linux-native"
16
17KMETA = "kernel-meta"
18KCONF_BSP_AUDIT_LEVEL = "2"
19
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060020SRCREV_machine ?= "195b2994f955071be3dd16ff61127dbc6b2e0069"
21SRCREV_meta ?= "48f7c852bd375b9340c68897ccd87ad89ead5f38"
Andrew Geissler220dafd2023-10-04 10:18:08 -050022
23PV = "${LINUX_VERSION}+git"
24
25SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
Patrick Williams169d7bc2024-01-05 11:33:25 -060026 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.6;destsuffix=${KMETA};protocol=https"
Andrew Geissler220dafd2023-10-04 10:18:08 -050027
28COMPATIBLE_MACHINE = "^(qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5)$"
29
30# Functionality flags
31KERNEL_FEATURES = ""
32
Patrick Williamsac13d5f2023-11-24 18:59:46 -060033KERNEL_DEVICETREE:qemuarmv5 = "arm/versatile-pb.dtb"