Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Protocol Buffers - structured data serialisation mechanism" |
| 2 | DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \ |
| 3 | serialization format. It includes libprotobuf-c, a pure C library that \ |
| 4 | implements protobuf encoding and decoding, and protoc-c, a code generator that \ |
| 5 | converts Protocol Buffer .proto files to C descriptor code, based on the \ |
| 6 | original protoc. protobuf-c formerly included an RPC implementation; that code \ |
| 7 | has been split out into the protobuf-c-rpc project." |
| 8 | HOMEPAGE = "https://github.com/protobuf-c/protobuf-c" |
| 9 | SECTION = "console/tools" |
| 10 | LICENSE = "BSD-2-Clause" |
| 11 | |
| 12 | DEPENDS = "protobuf-native protobuf" |
| 13 | |
| 14 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 15 | RDEPENDS_${PN}-compiler = "protobuf-compiler" |
| 16 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 17 | |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558" |
| 19 | |
| 20 | PV .= "+git${SRCPV}" |
| 21 | SRCREV = "dac1a65feac4ad72f612aab99f487056fbcf5c1a" |
| 22 | |
| 23 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git" |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | inherit autotools pkgconfig |
| 28 | |
| 29 | FILES_${PN}-compiler = "${bindir}" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |