blob: 52fe07acf9500626344ac747997805ce81271424 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
2HOMEPAGE = "https://github.com/platformdirs/platformdirs"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
5
6SRC_URI += " \
7 file://run-ptest \
8"
9
10SRC_URI[sha256sum] = "b0cabcb11063d21a0b261d557acb0a9d2126350e63b70cdf7db6347baea456dc"
11
12inherit pypi python_hatchling ptest
13
14DEPENDS += " \
15 ${PYTHON_PN}-hatch-vcs-native \
16"
17
18RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-appdirs \
20 ${PYTHON_PN}-covdefaults \
21 ${PYTHON_PN}-pytest \
22 ${PYTHON_PN}-pytest-mock \
23 ${PYTHON_PN}-pytest-cov \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}
28 cp -rf ${S}/tests ${D}${PTEST_PATH}/
29}
30
31BBCLASSEXTEND = "native nativesdk"