blob: a47cc717246ca19e081e732d3566b34c95831a1e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3DESCRIPTION = "strace is a diagnostic, debugging and instructional userspace utility for Linux. It is used to monitor and tamper with interactions between processes and the Linux kernel, which include system calls, signal deliveries, and changes of process state."
4SECTION = "console/utils"
5LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59a33f0a3e6122d67c0b3befccbdaa6b"
7
8SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
9 file://update-gawk-paths.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 file://ptest-spacesave.patch \
13 file://0001-strace-fix-reproducibilty-issues.patch \
14 file://skip-load.patch \
15 file://0001-configure-Use-autoconf-macro-to-detect-largefile-sup.patch \
16 file://0002-tests-Replace-off64_t-with-off_t.patch \
Andrew Geissler8f840682023-07-21 09:09:43 -050017 file://00ace1392f5bd289239b755458dcdeeed69af1da.patch \
18 file://f31c2f4494779e5c5f170ad10539bfc2dfafe967.patch \
19 file://3bbfb541b258baec9eba674b5d8dc30007a61542.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060020 "
Patrick Williams520786c2023-06-25 16:20:36 -050021SRC_URI[sha256sum] = "e17878e301506c1cc301611118ad14efee7f8bcef63b27ace5d290acce7bb731"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23inherit autotools ptest
24
25# Not yet ported to rv32
26COMPATIBLE_HOST:riscv32 = "null"
27
28PACKAGECONFIG:class-target ??= "\
29 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
30"
31
32PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
33PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
34
35EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror"
36
37CFLAGS:append:libc-musl = " -Dsigcontext_struct=sigcontext"
38
39TESTDIR = "tests"
40PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)"
41
42do_compile_ptest() {
43 oe_runmake -C ${TESTDIR} buildtest-TESTS
44}
45
46do_install_ptest() {
47 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
48 mkdir -p ${D}${PTEST_PATH}/build-aux
49 mkdir -p ${D}${PTEST_PATH}/src
50 install -m 755 ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
51 install -m 644 ${B}/src/config.h ${D}${PTEST_PATH}/src/
52 sed -i -e '/^src/s/strace.*[0-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
53}
54
55RDEPENDS:${PN}-ptest += "make coreutils grep gawk sed"
56
57RDEPENDS:${PN}-ptest:append:libc-glibc = "\
58 locale-base-en-us.iso-8859-1 \
59"
60
61BBCLASSEXTEND = "native"