Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | # |
2 | # Copyright OpenEmbedded Contributors | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
7 | inherit python_pyo3 python_setuptools_build_meta | ||||
8 | |||||
9 | DEPENDS += "python3-maturin-native" | ||||
10 | |||||
11 | python_maturin_do_configure() { | ||||
12 | python_pyo3_do_configure | ||||
13 | cargo_common_do_configure | ||||
14 | python_pep517_do_configure | ||||
15 | } | ||||
16 | |||||
17 | EXPORT_FUNCTIONS do_configure |