blob: 7b6a6bd94c9e65a049166ca261a1b3dd2c7a6bdb [file] [log] [blame]
Patrick Williams705982a2024-01-12 09:51:57 -06001SUMMARY = "Classes Without Boilerplate"
2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
5
6SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30"
7
8inherit pypi ptest python_hatchling
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14DEPENDS += " \
15 python3-hatch-vcs-native \
16 python3-hatch-fancy-pypi-readme-native \
17"
18
19RDEPENDS:${PN}+= " \
20 python3-compression \
21 python3-ctypes \
22 python3-crypt \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-hypothesis \
27 ${PYTHON_PN}-pytest \
28 ${PYTHON_PN}-unittest-automake-output \
29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34 install ${S}/conftest.py ${D}${PTEST_PATH}/
35}
36
37BBCLASSEXTEND = "native nativesdk"