Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame^] | 1 | SUMMARY = "Classes Without Boilerplate" |
| 2 | HOMEPAGE = "http://www.attrs.org/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30" |
| 7 | |
| 8 | inherit pypi ptest python_hatchling |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | python3-hatch-vcs-native \ |
| 16 | python3-hatch-fancy-pypi-readme-native \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN}+= " \ |
| 20 | python3-compression \ |
| 21 | python3-ctypes \ |
| 22 | python3-crypt \ |
| 23 | " |
| 24 | |
| 25 | RDEPENDS:${PN}-ptest += " \ |
| 26 | ${PYTHON_PN}-hypothesis \ |
| 27 | ${PYTHON_PN}-pytest \ |
| 28 | ${PYTHON_PN}-unittest-automake-output \ |
| 29 | " |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH}/tests |
| 33 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 34 | install ${S}/conftest.py ${D}${PTEST_PATH}/ |
| 35 | } |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |