blob: 860f2914769ee529fd8c0a54d5ed2f079b28527a [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Modern password hashing for your software and your servers."
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
6DEPENDS += "${PYTHON_PN}-cffi-native"
Patrick Williams520786c2023-06-25 16:20:36 -05007LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', ' -fuse-ld=bfd', '', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Patrick Williams705982a2024-01-12 09:51:57 -06009SRC_URI[sha256sum] = "33313a1200a3ae90b75587ceac502b048b840fc69e7f7a0905b5f87fac7a1258"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
Andrew Geissler028142b2023-05-05 11:29:21 -050011inherit pypi python_setuptools3_rust ptest-cargo cargo-update-recipe-crates
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13SRC_URI += " \
14 file://run-ptest \
15"
16
Andrew Geissler028142b2023-05-05 11:29:21 -050017CARGO_SRC_DIR = "src/_bcrypt"
18
Patrick Williams2390b1b2022-11-03 13:47:49 -050019require ${BPN}-crates.inc
20
Andrew Geissler9aee5002022-03-30 16:27:02 +000021RDEPENDS:${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050023 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000024"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30
31RDEPENDS:${PN}:class-target += "\
32 ${PYTHON_PN}-cffi \
33 ${PYTHON_PN}-ctypes \
34 ${PYTHON_PN}-shell \
35 ${PYTHON_PN}-six \
36"