blob: 505acb024ba3edddb8aaab057008141607b68712 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "Demo application to showcase 3D graphics using kms and gbm"
2DESCRIPTION = "kmscube is a little demonstration program for how to drive bare metal graphics \
3without a compositor like X11, wayland or similar, using DRM/KMS (kernel mode \
4setting), GBM (graphics buffer manager) and EGL for rendering content using \
5OpenGL or OpenGL ES."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
7LICENSE = "MIT"
8SECTION = "graphics"
Patrick Williamse760df82023-05-26 11:10:49 -05009DEPENDS = "virtual/libgles3 virtual/libgles2 virtual/egl libdrm virtual/libgbm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
12
Patrick Williams169d7bc2024-01-05 11:33:25 -060013SRCREV = "96d63eb59e34c647cda1cbb489265f8c536ae055"
Patrick Williams705982a2024-01-12 09:51:57 -060014SRC_URI = "git://gitlab.freedesktop.org/mesa/kmscube;branch=master;protocol=https \
15 file://0001-cube-gears-Change-header-file-to-GLES3-gl3.h.patch \
16 "
Patrick Williams2a254922023-08-11 09:48:11 -050017
Brad Bishop316dfdd2018-06-25 12:45:53 -040018UPSTREAM_CHECK_COMMITS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20S = "${WORKDIR}/git"
21
Patrick Williams705982a2024-01-12 09:51:57 -060022BASEPV = "0.0.1"
23PV = "${BASEPV}+git"
24
Brad Bishop6dbb3162019-11-25 09:41:34 -050025inherit meson pkgconfig features_check
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026
27REQUIRED_DISTRO_FEATURES = "opengl"
Brad Bishop19323692019-04-05 15:28:33 -040028
29PACKAGECONFIG ??= ""
30PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
Andrew Geissler9aee5002022-03-30 16:27:02 +000031
32CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
33