Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | require libcap-ng.inc |
| 2 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 3 | FILESEXTRAPATHS:prepend := "${THISDIR}/libcap-ng:" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 4 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 5 | SUMMARY .= " - python" |
| 6 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 7 | inherit lib_package autotools python3targetconfig |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 8 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 9 | # drop setuptools when version > 0.8.3 is released; it's needed only for distutils |
| 10 | DEPENDS += "libcap-ng python3 swig-native python3-setuptools-native" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/libcap-ng-${PV}" |
| 13 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame^] | 14 | EXTRA_OECONF += "--with-python3" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | do_install:append() { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 17 | rm -rf ${D}${bindir} |
| 18 | rm -rf ${D}${libdir}/.debug |
| 19 | rm -f ${D}${libdir}/lib* |
| 20 | rm -rf ${D}${libdir}/pkgconfig |
| 21 | rm -rf ${D}${datadir} |
| 22 | rm -rf ${D}${includedir} |
| 23 | } |
| 24 | |
| 25 | # PACKAGES = "${PN}" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN} = "${libdir}/python${PYTHON_BASEVERSION}" |
| 28 | FILES:${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 29 | |