Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Analyze Suspend" |
| 2 | DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \ |
| 3 | the activity between suspend and resume, allowing them to identify \ |
| 4 | inefficiencies and bottlenecks." |
| 5 | HOMEPAGE = "https://01.org/suspendresume" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 8 | |
| 9 | # Apart from the listed RDEPENDS, analyze-suspend depends on some features |
| 10 | # provided by the kernel. These options are: |
| 11 | # - CONFIG_PM_DEBUG=y |
| 12 | # - CONFIG_PM_SLEEP_DEBUG=y |
| 13 | # - CONFIG_FTRACE=y |
| 14 | # - CONFIG_FUNCTION_TRACER=y |
| 15 | # - CONFIG_FUNCTION_GRAPH_TRACER=y |
| 16 | |
| 17 | RDEPENDS_${PN} += "python-core python-datetime python-stringold" |
| 18 | |
| 19 | SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https" |
| 20 | SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | do_install() { |
| 25 | install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py |
| 26 | install -Dm 0644 README ${D}${docdir}/analyze-suspend/README |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native" |