Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "xfce4-session is a session manager for Xfce 4 Desktop Environment" |
| 2 | SECTION = "x11" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88" |
| 5 | |
| 6 | DEPENDS = "libwnck3 libsm libxfce4ui virtual/libx11" |
| 7 | |
| 8 | inherit xfce update-alternatives features_check |
| 9 | |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}" |
| 13 | PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit" |
| 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://0001-configure.in-hard-code-path-to-iceauth.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "5ad23062fd08ef5f5ad9b4389c7b54c6" |
| 19 | SRC_URI[sha256sum] = "fbe3a4a60c91589a2024ce12b2d2667625a8fedcbc90ef031831f56319f597af" |
| 20 | |
| 21 | ALTERNATIVE_${PN} = "x-session-manager" |
| 22 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/xfce4-session" |
| 23 | ALTERNATIVE_PRIORITY_${PN} = "100" |
| 24 | |
| 25 | FILES_${PN} += " \ |
| 26 | ${libdir}/xfce4/*/*/*.so \ |
| 27 | ${libdir}/xfce4/session/*-*-* \ |
| 28 | ${datadir}/xsessions \ |
| 29 | ${datadir}/themes/Default/balou/* \ |
| 30 | ${datadir}/polkit-1 \ |
| 31 | " |
| 32 | |
| 33 | RDEPENDS_${PN} = " \ |
| 34 | dbus-x11 \ |
| 35 | iceauth \ |
| 36 | netbase \ |
| 37 | upower \ |
| 38 | xinit \ |
| 39 | xrdb \ |
| 40 | " |